Back to overview
Downtime

Redis service failure

Sep 02 at 09:20pm UTC
Affected services
Mastodon Timeline
Mastodon Web
Mastodon Streaming API

Resolved
Sep 03 at 02:20am UTC

Removal of monitor and rebuild of the timelines in redis was completed. After service restart, all systems were back to normal operations. Some post updates may be delayed until cross server syncs complete.

Created
Sep 02 at 09:20pm UTC

An attempt to add monitoring and service tending backfired when the tooling instead repeatedly restarted the redis service, preventing Mastodon from being able to update timelines. The monitor was removed, but the restarting had corrupted the redis saves, requiring a complete rebuild of user timelines in order to allow Mastodon to start properly.